Computer Tips -Tech Info



« | »

Ubuntu 9.04 Jaunty Netbook Remix on an Acer Aspire One ZG5 trackpad issues

Recently I had the opportunity to work on an Acer Aspire One netbook. It’s rare that I get the chance to work on a linux desktop system for a client. Most of my desktop users that I support run Windows (although I primarily run linux on my machines.) I get to do a fair amount of server level work with linux variants, but this one, being a desktop install, intrigued me.

The issue was that the buttons on the trackpad didn’t work. She also indicated that she had tried a usb mouse and those buttons didn’t work either. As I looked at it, I had already spent some time browsing through bug reports getting ideas on what might be the issue. It behaved exactly as she described and so then the real fun began.

I looked at the xorg.conf file from /etc/X11/ – it looked normal (it was the default config file) I first tried doing some edits to clearly specify the trackpad device (cursor movement with the trackpad had been working though, it was just the clicks that weren’t registering.

So, after making changes I restarted gdm (the greeter) ( /etc/init.d/gdm restart ) and gave a try. Some things started working, tapping the trackpad substituted for the left click and the right click work. The external mouse worked with both buttons.

So, I chipped away a bit more. I verified that the files existed for some of the appropriate packages, some I reinstalled. I uninstalled compiz (having read a bug report related to that) I reverted to an older version of xinput-synaptic and came back to current. I tried mapping the mouse buttons with an .xmodmap file.

Nothing productive.

One thing that I did notice was that the right trackpad or both mouse buttons would work only when I had restarted gdm, not on a freshboot. So, I started looking at the boot process and the output in /var/log/Xorg.0.log to see if there was anything significantly different being reported there. Nothing useful.

I disabled the “dontzap” feature that’s new in jaunty. If you read the release notes they have disabled the ability to “kill off” the graphical interface with ctl-alt-backspace… I essentially re-enabled that option so it’s quickly and easily possible to restart the gui.

The bottom line of what I found was this. If you’re moving the mouse (trackpad) when gdm first starts, the mouse buttons will be usable (with the exception of the left button on the trackpad (!)) If you don’t move the mouse at the startup of gdm it get’s “stuck” in pointer mode… I can bring the cursor down over the “options” menu in the lower left corner of the greeter screen and it still holds it’s i-beam icon as though you are editing a text window, the options does not highlight on the mouseover and no right/left click/tapping will work until gdm is blown away and restarts with a ctl-alt-backspace.

After that everything works with the exception of the left trackpad button (although you can tap.) I tried reversing the buttons and it’s still the one on the left that doesn’t function.

Wondering if I was missing something I tried an experiment. I (using another computer) installed Jaunty 9.04 to a USB hard drive and brought it up to date with all the current updates. I booted this usb hard drive on three or four systems and it worked marvelously (hardware detection “just worked” on each machine.) The only one to exhibit any problems was this Acer Aspire One ZG5. Guess what the problems were? well…. if I didn’t move the mouse when the greeter screen first came up I wasn’t able to do any mouse clicking (the pointer seemed frozen in the i-beam cursor icon mode) and even if I did (or restarted gdm) the left button did not work.

I came to the conclusion that there were two different issues, one I suspected may be a software issue and an update could fix it (the initial boot problem with useless buttons.) The second problem (left click not working) could just be a hardware issue – since it only affects the trackpad and not an external mouse. As I think about it, I do wonder if the trackpad were faulty (left button) could it cause the other problem when it’s first initialized (?)

If I knew I would have access to the machine again I might have filed a bug report with Ubuntu to see if they could get someone to verify this as software issue (or not). SInce I won’t have access to it, I wouldn’t be able to follow up with more information if they needed it, so instead of a bug report I’m posting here.

The only way to know for sure if it’s Ubuntu 9.04 or the netbook is to have an identical model to test, which I don’t.

So, does anyone out there have the same IDENTICAL model netbook – with jaunty 9.04 – are you seeing a similar problem or does it work just fine? The updates on this machine were current as of June 1, 2009.

Comments are open in case anyone has some input on the issue.

Related Posts

Blog Traffic Exchange Related Posts Blog Traffic Exchange Related Websites
PDF24    Send article as PDF   

Posted by on June 3, 2009.

Tags: , , , , , , , , ,

Categories: Computers, Hardware, Linux, Linux Software, Linux Tech Support, Tech Support, Ubuntu

One Response


  1. credit repair…

    In today’ s struggling economy, a good credit score is more important than ever. A credit score that was good enough to get a loan in the past may not cut it as easily today. Creditors are tightening the reins on lending, while credit scores are increa…

    by credit repair on Aug 9, 2009 at 1:29 am

You must be logged in to post a comment.

« | »




Recent Posts


Pages



Switch to our desktop site